22nd April 2017

Cloud Servers Host server unresponsive: ps149

Hosts ps149 has become unresponsive and Cloud Servers running on it are currently unavailable. We're investigating and will provide further information as soon as possible.

UPDATE: The affected host has now been rebooted and Cloud Servers which are currently unavailable will be started up again shortly. We're continuing to investigate the cause of the crash.

UPDATE: All affected Cloud Servers have now been started back up.